Missing libilbc.so / doesn't start on Linux


(citruskoala) #1

I am currently running ubuntu bionic beaver on my laptop, no windows, just linux. My specs are

  • Intel Celeron Dual-Core 3205U 1.5 GHz Processor (Broadwell micro-architecture)
  • 4 GB DDR3L SDRAM
    -16 GB Solid-State Drive
    -15.6-Inch Full HD IPS Screen, Intel HD Graphics
    I have followed all the instructions on the readme file, marked launch.sh as executable, and when I tried running it, nothing happened, and I have gotten the same result multiple times afterwards, is this a software or hardware issue?

(The Third Duke of Silly) #2

Probably a software issue.
I’ll let @hhyyrylainen deal with it


#3

You should run launch.sh in terminal to see the output. It is probably a missing library.


(citruskoala) #4

I tried that, and the terminal opened for under a second and then closed, I couldnt read anything it said.


#5

You need to open terminal first then cd the_folder_where_launchsh_is to switch to the folder and then run ./launch.sh to have the terminal stay open so that you can read what it says.


(citruskoala) #6

Here is the message it has given me."./Thrive: error while loading shared libraries: libilbc.so.0: cannot open shared object file: No such file or directory" I have tried the exact same process but it still hasnt given me any different errors.


#7

That error is (in my opinion) quite clear, you are missing libilbc. If you are using Fedora or Ubuntu you can use the package manager to install it. Some other distros might also package it but at least things like mint are missing it. So using those distros you need to download the libilbc source code and then compile and install it. You might also need to create a symlink with a fixed name as the created library might have a slightly different name.

Edit: I have renamed this thread for future reference


(𝑻𝒉𝒆 π‘±π’π’π’π’š π‘¬π’Žπ’‘π’†π’“π’π’“ 𝒐𝒇 𝑺𝒆𝒂𝒇𝒐𝒐𝒅) #8

Wait a minute, fedora is a real operating system?


(Narotiza) #9

This is apparently a very common issue on Linux, I’ve run into it and I’ve seen plenty of other users running into it as well. Will it be fixed in 0.4.0? I haven’t tried it yet


#10

This wouldn’t have been a problem if other packagers weren’t so oblivious to necessary libraries (I just checked and Fedora is probably the only one that ships it by default, but Ubuntu has .deb packages available for it unofficially).

I think it was used by ffmpeg. This should not be a problem any more as I changed ffmpeg to not link to any external libraries. But if you are not using Ubuntu in my opinion you should be prepared to compile some less common software yourself, because you must have been told that if you are a Linux beginner you should stick with Ubuntu (or another debian / Ubuntu derivative) or else you are not going to have fun.