0.5.4 Release Candidate Testing

Release of 0.5.4 is coming on June 19th, which is quite a bit later than intended. There was originally supposed to be a release right after 0.5.3.1 when binding agents were supposed to be done, but that didn’t happen. In fact the last thing to go into 0.5.4 will be the binding agents. Here’s an early build for testing, this still has quite a few serious binding agent bugs, so keep auto save on to not lose too much progress. We hope that the upcoming last week before release will give us time to fix at least some of the most serious bugs.

As always here are the downloads for the release candidate:
Linux: https://dev.revolutionarygamesstudio.com/api/v1/download/13172
SHA3: 0db7a1c17326f91c9650158ed456e7cd3ac03c6411af612d68d69c1062885bb3

Windows: https://dev.revolutionarygamesstudio.com/api/v1/download/13174
SHA3: ba1a0790b19375521193c6b457f75defc7ce1e57a04feb822a4192fe3d2d2f41

Windows (32-bit): https://dev.revolutionarygamesstudio.com/api/v1/download/13175
SHA3: c71657ea201667ec44b69af459bb710db7274180229e0d13657e0d5858e0870e

Mac: https://dev.revolutionarygamesstudio.com/api/v1/download/13173
SHA3: ab53851ba42df39930a36cf4796af92237f1de358015509679341e2dd885b1e0

Note for patrons, you can download the latest BOTD to get the same builds as the RC through the launcher.

Here’s the known bugs with the binding agents:

Please focus on reporting serious crashing or gameplay issues. Also we’d like to know how the new storage balance changes feel, as we can still tweak those for the upcoming release.

7 Likes

Game crashes when I try to bind 3 cells

Error log:

I also crash when binding 3 cells:

Moved the post here as the release candidate feedback and crashes is meant to be in this thread, only once the 0.5.4 release is out, then separate bug reports should be made.

Game will occasionally crash whenever I try to disband a colony.

What file + line in Thrive causes this error? The Godot debugger generally also displays something like this for these kind of errors:

these are for multicellular right?

I made a bug report, thrive for mac is corrupted!

Continuing the discussion from 0.5.4 Release Candidate Testing:

The thing that happened is self-explainatory

Nope don’t continue in a separate thread, as I said all release candidate testing feedback needs to go into the one thread.

but what happened, please look into it.

That’s the hard part. Godot doesn’t tell you the callstack for those errors, so it’s very hard to debug them.

Looks like Godot broke their mac packaging again. Could you try the workaround in here: Make release script set execute bit on mac export · Issue #1527 · Revolutionary-Games/Thrive · GitHub
If the workaround works, I can edit our build scripts again to fix that.

1 Like

it did’nt work. it said the same error.

I don’t have a mac and my experience using a mac is limited so how much I can help is limited.
If you used the normal unzip method, it’s possible that the extracted app was marked as untrusted. Is there like a right-click option to unblock the app either on the .zip or the extracted .app? If you use homebrew to install p7zip you should be able to probably use that to unzip the .zip file without marking the extracted .app as not allowed to run.

Perhaps @Nunez2196 can help more?

Yep, that looks to be the same errors as in here: Fix sometimes happening crashing when forming cell colonies · Issue #2311 · Revolutionary-Games/Thrive · GitHub

that allows you to open an app that’s flagged, not one that’s corrupted.

The corruption message is a lie, at least in my experience apps that aren’t properly signed or don’t have the execute permission set, will return the exact same error.
I can’t try this myself because I don’t have a mac. The mac support is very much experimental until I get a mac to test on. Or someone with a mac steps up to be the maintainer of Thrive for mac, it’s going to be really flakey. If we get enough patrons that want mac builds that the cost of buying a mac is covered, then a mac can be arranged for me to develop on. Until then, we are in the current situation.

Are you sure, i’ve downloaded some flagged apps, and they said that it’s flagged, not corrupted.

I’m pretty sure the error message with the Thrive executable not being marked as an executable was that corrupt warning. That’s all I can say without me personally having a mac to test and develop Thrive on. Right now the build process is that Godot makes a .zip file that our build script just adds a few files to, so Godot’s packaging is likely at fault here…

that’s what i was saying