0.6.4 General Feedback Thread

0.6.4 is out now. Details on GitHub: Release Thrive 0.6.4 · Revolutionary-Games/Thrive · GitHub

In this thread you can provide the usual quick feedback about the new release without needing to make separate threads about your findings. is out now so that should be used now to play Thrive and give feedback on.

Maybe someone would now be encouraged to make a feedback post with most of the big bugs gone?

I don’t know if this has been reported yet, but I exited editor by pressing space with vacuole upgrade menu on. It still lasted in main game until game crashed upon clicking “Cancel” button on the upgrade menu.

Yes, that’s been reported before:

There’s even a fix, but it hasn’t been fully completed as the author of the PR has gone inactive:

1 Like

Some microbe managed to take away my player cell from multicellular organism and digest it. Other than that I can see that

work well (it’s not like only these work, these were just the only ones I remember checking).

1 Like

It’s good that that didn’t crash (this was actually a thing to check on the ECS task board). And the game is working fully as intended if a colony member or leader can be engulfed away. That’s how it should also function in 0.6.3.


I didn’t mention that microbe which engulfed me was - from what I remember - smaller than me I think it is caused by cell being grown enough big in size (even if not visually bigger than me) to engulf me (I saw some posts about this but I couldn’t find it now).

Yes, even if the fossilization dialog’s base size of a species is smaller than you it can be almost fully grown to have doubled in organelle count to engulf things it wouldn’t normally be able to engulf.


I ran Thrive on Godot and in multicellular freebuild I started engulfing other cells. Game crashed and I tried to replicate the bug on official release version. It didn’t crash but gave me the same unhandled exception:

Failed to unbind colony of a dying lead cell
Engulfed something that couldn't have AABB calculated (graphical instance: [Spatial:95687])
Engulfed something that couldn't have AABB calculated (graphical instance: [Spatial:95639])
Engulfed something that couldn't have AABB calculated (graphical instance: [Spatial:95616])
Engulfed something that couldn't have AABB calculated (graphical instance: [Spatial:95630])
Entity is stuck inside a dead engulfer!
------------ Begin of Unhandled Exception Log ------------
The following exception prevented the game from running:

System.InvalidOperationException: Entity is inside a dead engulfer (not ejected)
  at Systems.EngulfedHandlingSystem.Update (System.Single delta, DefaultEcs.Entity& entity) [0x00142] in C:\Users\makow\Documents\Folder\Godot_v3.4.4_Mono\Thrive\Thrive\src\microbe_stage\systems\EngulfedHandlingSystem.cs:90 
  at DefaultEcs.System.AEntitySetSystem`1[T].Update (T state, System.ReadOnlySpan`1[T] entities) [0x0000f] in <71cea9262b2d4f47b57b59fbd6ae9b26>:0 
  at DefaultEcs.System.AEntitySetSystem`1[T].Update (T state) [0x000c3] in <71cea9262b2d4f47b57b59fbd6ae9b26>:0 
  at MicrobeWorldSimulation.OnProcessFixedLogic (System.Single delta) [0x000eb] in C:\Users\makow\Documents\Folder\Godot_v3.4.4_Mono\Thrive\Thrive\src\microbe_stage\MicrobeWorldSimulation.cs:333 
  at WorldSimulation.ProcessLogic (System.Single delta) [0x000ad] in C:\Users\makow\Documents\Folder\Godot_v3.4.4_Mono\Thrive\Thrive\src\general\base_stage\WorldSimulation.cs:176 
  at WorldSimulation.ProcessAll (System.Single delta) [0x00001] in C:\Users\makow\Documents\Folder\Godot_v3.4.4_Mono\Thrive\Thrive\src\general\base_stage\WorldSimulation.cs:126 
  at MicrobeStage._Process (System.Single delta) [0x0008c] in C:\Users\makow\Documents\Folder\Godot_v3.4.4_Mono\Thrive\Thrive\src\microbe_stage\MicrobeStage.cs:197 

Please provide us with this log, thank you.
------------  End of Unhandled Exception Log  ------------

(Is it okay to send shortened logs on community forums or should I use pastebin either way?)

Also, if engulfing capacity should be equivalent to cell size, then (in multicellular freebuild too) that was not the case with my cell. Cell size was like 31 I think (I don’t remember fully) and ingested matter bar showed maximum value as 51 or something like that.

This enables extra debug checks.

This is exactly one of those debug checks. It’s in the code to remind me (or any other programmer) that there’s a unhandled engulfing case that needs code to get out of the bad state.

This is the intended 50% buff to engulfing size that eukaryotes get. Didn’t it also apply to storage in 0.6.3? If it doesn’t apply to storage as well then there could be cells that you should be able to technically engulf but due to storage size wouldn’t be able to be engulfed.

1 Like

the multicell engulfing bug is back, and i just got instakilled by engulfing a slightly spiky cellulose walled cell after changing my starting cell membrane to lipid to get around the first one

Could you please clarify?

The pilus reimplemented damage cooldown is not in It’s coming in the next release. Or available already in the devbuilds to patrons.

i can’t use lipid cells to engulf when my main cell isn’t lipid in early multicell

So you mean that if your main cell cannot enter engulf mode, then other cells in the colony that should be able to enter engulf mode cannot do so either?

Edit: okay I can confirm the engulf button doesn’t appear correctly when colony grows and does have cells that can engulf things in it.

Edit 2: well this is a pretty silly typo to have made:

Edit 3: made a fix:

I have had many occasions where an enemy engulfing a cell from my multicelled creature other than the stem cell actually engulfs the stem cell instead. It zooms over to the enemy cell, and the whole colony dies.

Also, I’m not sure if this is the same issue as was previously reported, but If a cell is spawned in the multicell colony at a position where an AI cell with a pilus is, the newly spawned cell is instantly killed.

Edit: Here’s video evidence:

1 Like

What’s the alternative? Colonies get invulnerability frames for 0.5s or more when a new member is added?

This seems actually to be a bug. I would guess that somehow the collision data for the colony is not up to date or the added colony member has incorrect physics data, which results in the real cell lookup to fail so the engulfing resorts to acting on the colony lead cell. I’d be interested to take a look at any logs from when this happened or a save file where the problem is easy to trigger (so that I can investigate what actually goes on and try to find a fix).

I did already make one small real target cell lookup bug fix for 0.6.5, but it might not help here as I think the fix should only apply in cases where the game crashed before.

1 Like

Here’s the save from just before when my stem cell was swallowed:

Taking damage is reasonable for a cell that spawns into a sharp object, but it shouldn’t be instant death. I thought this might be the same bug that causes instant death when expelling a cell. If momentary invulnerability is the best way around this, then that would probably be fine.

1 Like

I got the feeling that the invulnerability frames I added might not even be in the last release. Because I’ve definitely added it. It might not come out to the public until 0.6.5.

Is it easy to trigger the bug based on the save?

1 Like

Yes. Just go to the left, and bump into one of the really big fellows. They’re only just off-screen.

1 Like