Crash Report


(Morwaul) #1

Hello

This game looks awesome but crashes. From what testing I have done it appears to crash only after the tutorial. If I hit escape to exit the tutorial or once I have exited the evolve screen the game will crash if I start swimming about. If I sit there not moving after exiting the tutorial it will not crash until I start moving.

PC Info:
Windows 10 64bit
16GB DDR4
i7-6700 CPU
Realtek HD Audio onboard (not used)
Cretive Audigy (using this one)
Nvidia HD Audio (from video card, not used)
GTX 960 Video

Playing Thrive 0.3.4

Thrive is running. Log output:

Process Started

Loaded new AlphaHit texture: ThriveGeneric.png (2701x1001)

LuaEngine init started Available Playback Devices: 0): Generic Software on SPDIF Out (Sound Blaster Audigy 5/Rx) 1): Generic Software on ASUS VW266H (NVIDIA High Definition Audio) 2): Generic Software on Speakers (Sound Blaster Audigy 5/Rx) 3): SB Audigy 5/Rx [DFC0] [DEFAULT] Attempting default device: SB Audigy 5/Rx [DFC0]

Thrive version 0.3.4 with Lua 5.1 from LuaJIT 2.0.4 ready to go. FPS: 56.5476 avg frame duration: 7.98948 ms FPS: 62.1302 avg frame duration: 6.66152 ms FPS: 61.9381 avg frame duration: 8.60420 ms FPS: 64.1658 avg frame duration: 7.75325 ms FPS: 61.6302 avg frame duration: 8.80771 ms FPS: 61.6915 avg frame duration: 8.38891 ms FPS: 62.1302 avg frame duration: 7.65324 ms FPS: 62.3145 avg frame duration: 7.95685 ms FPS: 59.6285 avg frame duration: 7.94916 ms FPS: 62.4381 avg frame duration: 7.81008 ms FPS: 63.7450 avg frame duration: 7.45328 ms FPS: 63.2411 avg frame duration: 6.31770 ms FPS: 62.9371 avg frame duration: 6.00888 ms FPS: 63.0000 avg frame duration: 6.94014 ms FPS: 49.3583 avg frame duration: 10.20443 ms FPS: 62.5621 avg frame duration: 9.87285 ms FPS: 47.4777 avg frame duration: 15.91908 ms played sound FPS: 64.0394 avg frame duration: 10.98346 ms FPS: 63.0542 avg frame duration: 11.09847 ms FPS: 62.8743 avg frame duration: 10.66741 ms FPS: 62.1915 avg frame duration: 10.94751 ms FPS: 63.0542 avg frame duration: 11.58963 ms played sound FPS: 63.6816 avg frame duration: 11.60335 ms played sound FPS: 63.0000 avg frame duration: 11.50192 ms played sound FPS: 63.7450 avg frame duration: 11.06342 ms FPS: 63.7450 avg frame duration: 11.23134 ms FPS: 62.2530 avg frame duration: 10.79455 ms FPS: 62.5621 avg frame duration: 10.84346 ms FPS: 62.3762 avg frame duration: 11.40444 ms FPS: 64.0394 avg frame duration: 11.39673 ms FPS: 62.1915 avg frame duration: 11.54609 ms FPS: 62.7490 avg frame duration: 11.69698 ms FPS: 63.2411 avg frame duration: 11.74856 ms FPS: 62.6866 avg frame duration: 11.97937 ms FPS: 62.6866 avg frame duration: 12.04577 ms FPS: 61.9381 avg frame duration: 12.29869 ms FPS: 60.7570 avg frame duration: 12.98582 ms FPS: 63.2411 avg frame duration: 12.58176 ms FPS: 62.6866 avg frame duration: 12.74255 ms FPS: 62.2530 avg frame duration: 12.45437 ms FPS: 63.6183 avg frame duration: 12.59913 ms FPS: 62.3762 avg frame duration: 12.65980 ms FPS: 61.0000 avg frame duration: 12.69680 ms FPS: 61.0837 avg frame duration: 12.90216 ms FPS: 63.1787 avg frame duration: 12.20877 ms FPS: 63.0000 avg frame duration: 11.86386 ms FPS: 61.6302 avg frame duration: 11.46536 ms FPS: 61.5079 avg frame duration: 12.20545 ms FPS: 61.8146 avg frame duration: 12.21684 ms FPS: 60.5159 avg frame duration: 12.48834 ms FPS: 62.0000 avg frame duration: 11.76672 ms FPS: 62.8116 avg frame duration: 11.79954 ms FPS: 62.6243 avg frame duration: 11.90854 ms FPS: 63.0000 avg frame duration: 12.40306 ms FPS: 63.4921 avg frame duration: 12.38183 ms FPS: 62.1302 avg frame duration: 12.41712 ms FPS: 62.3762 avg frame duration: 12.51364 ms FPS: 63.4921 avg frame duration: 12.01067 ms FPS: 56.9030 avg frame duration: 14.26110 ms FPS: 61.6915 avg frame duration: 13.68235 ms FPS: 60.9037 avg frame duration: 13.66486 ms FPS: 63.0000 avg frame duration: 13.49493 ms [Error] OpenAL Error: Invalid operation attempted…

[Error] OpenAL Error: Invalid operation attempted…

FPS: 63.6183 avg frame duration: 13.23052 ms FPS: 61.5690 avg frame duration: 11.84292 ms FPS: 59.3472 avg frame duration: 12.53927 ms FPS: 63.7450 avg frame duration: 13.25396 ms FPS: 59.3472 avg frame duration: 14.21060 ms FPS: 60.1578 avg frame duration: 14.24387 ms FPS: 60.9391 avg frame duration: 14.33783 ms [Error] OpenAL Error: Invalid operation attempted…

FPS: 61.9381 avg frame duration: 14.55439 ms [Error] OpenAL Error: Invalid operation attempted…

FPS: 58.9411 avg frame duration: 15.16550 ms FPS: 50.7968 avg frame duration: 16.35726 ms [Critical] OpenAL Error: Out of memory…

[Error] OpenAL Error: Invalid name passed as an argument to an AL call…

[Error] Failed to create Audio Source (microbemicrobemicrobe-movement-1180): Error creating audio source.

File …/sounds/soundeffects/microbe-movement-1.ogg doesn’t exist *** SoundSourceSystem::restoreSound() - Sound with name: soundeffects/microbe-movement-1.ogg failed to load! Lua error detected! Failed to restoreSound for new sound object: [C]:-1 (method update) …/scripts\lua_engine\game_state.lua:186 (method update) …/scripts\lua_engine\lua_engine.lua:145 (method update) …/scripts\game.lua:39

[Error] OpenAL Error: Invalid operation attempted…

[Error] OpenAL Error: Invalid operation attempted…

[Error] OpenAL Error: Invalid operation attempted…

[Error] OpenAL Error: Invalid operation attempted…

[Error] OpenAL Error: Invalid operation attempted…

[Error] OpenAL Error: Invalid operation attempted…

[Error] OpenAL Error: Invalid operation attempted…

ERROR: [wmv3 @ 37002520] Extra data: 8 bits left, value: 0 [wmv3 @ 371df860] Extra data: 8 bits left, value: 0

child process exited with code 0

Thrive has exited normally.


(Morwaul) #2

Further testing. I switched to a USB Headset that I have and it appears to be working without crashing. Guessing it does not like the creative drivers or something.


#3

It is known that the sound doesn’t want to work with some sound cards / devices. There is a potential workaround with replacing the bundled openal.dll as described here: