Custom emoji images are broken

The ‘thrive’ emote doesn’t show up, I’m not sure if this is only on my end but I thought I’ll let people know.


not just you
its both the thrive emote and the f emote

1 Like

Yes, i believe hhyyrylainen talked about this earlier. (i think on the misc thread.) hopefully it doesn’t spread to other emotes.

1 Like

Discourse doesn’t correctly set the URLs for custom emoji when using a CDN.
I tried to report it to them but so far they haven’t fixed it. I even tried to fix it myself but I didn’t get it working so I tried asking for development help:

so far no replies.

Found my previous post on here about this:

1 Like

As Discourse isn’t in a hurry to fix this, I investigated if it is safe to turn off the block for public access to the forum file storage. And it seems it is safe, even though in the Wasabi console it has a big warning that people have “read and write access to this file” it seems that the actual permission is just to read.
I did try to use aws CLI to verify and it seems so, also in my tests I couldn’t anonymously delete or upload things. So I hope everything is okay.

Because of that change the custom emoji should now load on the site, but it doesn’t go through the CDN properly as Discourse didn’t fix that. But at least it should show up right, and unless there’s a ton of traffic on it, it shouldn’t cause issues.

If anyone knows better (AWS S3, Wasabi) or finds an exploit please message me ASAP as being able to replace or upload new files to the forum uploads bucket would be a serious security issue.