Different keyboard configurations

I’d like to report a problem I’ve faced both while trying to type and to change keybinds.
Basically, my keyboard has an Italian layout (it looks similar to File:Italian Keyboard layout.svg - Wikimedia Commons), which is different from English keyboards. As a result, typing certain keys gives me a different output from what I’m expecting. For example, if I press “+”, the game thinks I’m pressing “=”. I suppose other languages may face this as well. Has anybody else experienced this?

What is weird is that I’ve never encountered this problem in any game I played except this one.
I wouldn’t say this is a priority fix (as most keys do work), however it may be worth considering to improve game experience.

P.S.: before submitting this post I made a quick search and found this post: [TOTW] Most Desired Features for 0.4.1 and the Future! - #29 by bur. Not much to say, except that changing keybinds does not solve things completely, as precedently stated. If I were to change a keybind to the button that looks like “+” on my keyboard, the menu would state that the new key would be “=”. Which would be confusing, especially if I later forgot the keybind, checked it on the menu, and tried to hit what looks like “=” on my keyboard, in vain.

Have you checked that your computer is configured with italian layout? It happened to me that the computer changed suddenly layout configuration

1 Like

It is.

What is mega-weird (and I just noticed) is that Q doesn’t work while typing in text boxes (for example species name), while ò, à, ù, è all work; but when changing keybinds, it’s ò, à, ù, è, among others, which are incorrect.


Pic: here I tried typing the numbers, qwerty, and òàùè+ì.

Cattura2
Second pic: here I tried adding ò as a keybind.

BTW, game language does not affect this behaviour.

Sounds like a Godot engine issue. I have a nordic layout keyboard and I can type all the special characters fine like “äöå=[@”
Though yeah, the keybindings, it doesn’t always know special key names like “ö” gets shown as 246 in the keybindings menu for me.

You could download the Godot editor and see if the new project name text box in it works correctly for you or not. If it doesn’t this needs to be reported to Godot engine as a text input bug.

I opened an issue about the keybindings not showing the key correctly:

Though does it at least work if you press the key you bound to the move forwards action? Even if it doesn’t show correctly.

Edit: Godot 3.4 added a new feature of having physical scan codes that are layout independent, they might be useful for something in this context:

1 Like

Cattura3
Yes, I can type everything no problem.

Yes. It does respond correctly if I press the key intended (ò). It just shows an incorrect one (’).

So the issue with keybindings is covered by that one issue I linked.

But then what about inputting “q”? So it doesn’t work in any of the text boxes in Thrive, but does work in the Godot editor?

Yes, it can be seen in the picture I provided. The"q" part is definitely the weirdest one. Maybe it’s just my computer? Although, even on my computer, the key works for everything except Thrive textboxes.

I’ll see if I can get permission to install Thrive on someone else’s computer to compare.

Edit: I’d like to add that the apostrophe ( ’ ) key also doesn’t type anything in the text boxes, whereas the input menu thinks it’s the open curly brace ( { ) key. Q does get correctly reported as Q by the input menu, but, as we discussed, cannot be typed.

Cattura4
Picture: this should be an apostrophe ( ’ ).

Opened an issue about the not being able to type certain characters problem:

UPDATE: I have made a fresh install on a second, borrowed computer (also Italian and Windows), and the keys Q and ’ are typeable there. The other problem (keys shown incorrectly by the inputs menu) persists.