Game Freeze on Launch

I just recently got the game, but I have only ever seen the main menu once. Every time I launch I see the Thrive Splash screen and then the game immediately stops responding. I have tried the Skip video and GLES2 settings in launcher, to no avail. I have restarted my computer as well. I have also tried running the game from cmd line and the game always stops responding after loading the locale files, but never generates any crash logs. I have no issue opening Godot by itself or opening the project in the godot editor, sans missing depenencies. I am at this point at a loss as to why the game does not run.

My specs are AMD Ryzen 7 7700x and a Radeon 6800.

1 Like

did you try re-installing the game? it is possible that your installation is corrupted, which, based on the fact that i have worse specs than you and i can run thrive, it is more than likely that that is the case.

I did try reinstalling, I also tried older version of the game from Github, but none worked.

how did you install it? did you delete the thrive folder completely before re-installation?

For the windows version of the game I completely deleted the folder, for the steam version I used the uninstaller.

can you start the game and use pastebin to link the log as the log might contain information on why it is freezing

Is the CMD line output for running the latest windows version. The steam version fails to ever output anything in the log folder in roaming, or any dumps in the launcher.

which version is that from?

That is from version 0.6.0 for windows, though the output is the same from other versions and for the steam build or the standalone build from github

did you download it through the launcher

Yes, I also tried the launcher, and multiple builds.

Interesting that your log shows the localization files being loaded. I’ve not seen that before. Seeing as it probably loaded the final locale, I assume that whatever the engine does first after that is what causes the crash. It seems that none of the text that our code prints is in the log, which would means that none of our code gets to run before the crash happens.

Have you tried really old Thrive versions from before we had the crash reporter, like 0.5.0 or 0.5.1?

Also you said that you tested plain Godot, but did you try some example project (for example the 3rd person shooter sample)? We’ve had one user for whom the Godot editor started just fine, but when they tried a sample project that then crashed. This would be really good to try to figure out whether the problem is a general engine issue or something specific in Thrive.

I have no issue running any of the sample godot projects. I can open the thrive project from the source file, however, it seems to be missing dependencies for some reason.

I also thought it was strange it would load the language files with no issue and then promptly cease to respond and never recover.

Because git is very bad at managing large binary files, we use git LFS. If you don’t use git LFS to get the game files, you get just placeholder asset files.

We have setup instructions going over everything needed to get the game compiling and running on your computer:

I’ve never seen those log messages myself. If I had (or anyone else have logs with those in them?) we could compare to see what Godot will attempt to do just after the locale loading, which would probably be pretty enlightening in terms of narrowing down what is causing the problem.

I’ll take a peek at the full instructions to compile it locally here in a moment.

Those are not logs per se, but the stdout from cmdline when running the game that way. You could replicate this by launching the executable in either cmd or powershell. The game fails to produce any logs at all when it hangs. Windows event viewer provides no information beyond application hang with no details.

I use Linux, and even if I use wine to run the Windows version of an exported game, I just get the following:

$ wine Thrive.exe 
002c:fixme:winediag:LdrInitializeThunk wine-staging 8.0 is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on
007c:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
007c:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
007c:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
007c:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
Godot Engine v3.5.stable.mono.thrive.d2ad79a40 -
OpenGL ES 3.0 Renderer: AMD Radeon Graphics (gfx1100, LLVM 15.0.7, DRM 3.49, 6.2
Async. shader compilation: OFF
0108:fixme:win:RegisterTouchWindow hwnd 000000000002006A, flags 0 stub!
008c:fixme:imm:ImeSetActiveContext (0000000000010026, 0): stub
0108:fixme:imm:ImeSetActiveContext (0000000000010064, 1): stub
008c:fixme:imm:ImmReleaseContext (0000000000010020, 0000000000010026): stub
0108:fixme:imm:ImmReleaseContext (000000000002006A, 0000000000010064): stub
0108:fixme:avrt:AvSetMmThreadCharacteristicsW (L"Games",0000000003A2C010): stub
0108:fixme:avrt:AvSetMmThreadPriority (0000000012345678)->(2) stub

Mono: Log file is: 'C:/users/hhyyrylainen/Application Data/Thrive/mono/mono_logs
0108:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
This is Thrive version: (see below for exact build info)
Unhandled exception logger attached
Startup C# locale is: fi-FI Godot locale is: fi_FI
user:// directory is: C:/users/hhyyrylainen/Application Data/Thrive
Game logs are written to: C:/users/hhyyrylainen/Application Data/Thrive\logs lat
est log is 'log.txt'
Doing delayed apply for some settings
Set audio output device to: Default
Set C# locale to: fi-FI Godot locale is: fi
No SteamClient class found, not initializing Steam
SimulationParameters are good
This version of Thrive was built at Wednesday, 01 February 2023 08:43:53 from co
mmit c33d962a57a942fbeb2fb71fb7d0af2a48c4c87d on branch web_export
We are not started through the Thrive Launcher
Loading mod Nodes into the scene tree
Jukebox now playing from: Menu
Jukebox: starting track: res://assets/sounds/main-menu-theme-1.ogg position: 0
User requested program exit, Thrive will close shortly

Which doesn’t print any of the locale stuff or anything like that, which is why I find that log you posted very weird.

Huh. That is strange in comparison, however I believe it is because I use the verbose flag

If I don’t, it only spits out the video driver and OpenGL version.

That explains it.

Here’s the relevant part now from my logs:

Loading resource: res://locale/vi.po
Loading resource: res://locale/zh_CN.po
Loading resource: res://locale/zh_TW.po
Loading resource: res://assets/textures/gui/cursors/default.png
Mono: Initializing module...
Mono JIT compiler version 6.12.0 ((no/45efaa3b)
Mono: Log file is: 'C:/users/hhyyrylainen/Application Data/Thrive/mono/mono_logs
0108:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
Mono: Runtime initialized
Mono: Loading assembly mscorlib...
Mono: Assembly mscorlib loaded from path: .mono/assemblies/Release/mscorlib.dll
Mono: Loading scripts domain...
Mono: Creating domain 'GodotEngine.Domain.Scripts'...
Mono: Loading assembly GodotSharp...

So it looks like for you the game crashes before it can successfully load the cursor image, which is part of Godot initialization when it is reading the project configuration.

The next step would be to start the mono initialization. Well, maybe your logs are missing the last few messages due to the crash. But I strongly suspect that the custom cursor property we have enabled or the fact that we are a mono game, triggers a Godot engine bug on your computer.

After following the instructions for git lfs, most of the dependencies were fixed sans two cs files.

Happens after following all the instructions up to the import bit

Is that the mono version of Godot? There should be a “build” button in the top right next to the “GLES3” selector, but your screenshot doesn’t have that.