Game resolution

Hello! It’s me again.
Whenever I play Thrive, I think the resolution is less than expected. Is this expected to happen? Detail:I use a 4K TV as a monitor. Is because of the 4k TV? I apologize for any inconvenience that may be causing you.I don’t know if you can see the image resolutions as same as I do, but down here is the image!

1 Like

It looks like you have scaling enabled in Windows. Thrive doesn’t have any special feature to tell Windows to not do scaling on it. So Windows tells thrive to render to a smaller window, which is then upscaled by Windows, with the end result being blurry. This is the case with all programs that haven’t been programmed to be scaling aware in Windows.

1 Like

So, is there something I have to do? Or this has no solution?

You can disable scaling in Windows to fix Thrive, and likely a bunch of other programs as well, being blurry.
The upcoming Godot version of Thrive (which will be 0.5.0), might scale correctly. If it doesn’t either then a feature request needs to be submitted to Godot to add scaling support.

1 Like

Thank you Thrive Lord! Good luck in the engine switch! :grinning:


Sorry for noticing it just now :neutral_face:, but the Godot build doesn’t scales correctly. So did you mean that I have to scale it correctly in the future or it is really a problem? :no_mouth:

edit: I know almost nothing about programming and switching engines, so I may speaking stupid

It seems that Godot does support handling Windows scaling:
Though, we’ll need to enable the option in Godot. I’ll make a note of enabling that feature before 0.5.0 is released.

It has now been turned on, so let’s hope that 0.5.0 works for you once released:

1 Like

Hahaha I was reading that thing in Github now!
Still congratulations and thank you for all people who contributed! :thrive: :wink:
YES yes yes