Linux - crash at start (SIGILL)

Game crashing at start on Linux :confused:
Using Solus fully up to date.
It opens a black screen but closes afterwards leaving an log.


Crash dmp:

1 Like

That’s an interesting crash.
The crash reason is: illegal instructions. Which means that if there wasn’t some serious stack or memory corruption, then your CPU encountered an instruction it doesn’t know.
Looking at your CPU model: AMD Athlon™ 64 X2 Dual Core Processor 5200+ it seems to have been released in 2007… which means that this very much might be the case that the game is compiled with some newer extension instruction that your CPU can’t handle.

I don’t build the game on my computer with the instruction set support cranked up to latest, so this is a pretty unusual situation. It seems that the default GCC options have been decided that they don’t need to work on that old CPU.

I think if you compile the game yourself on your computer, it should be able to build a version that doesn’t use any new instruction set extensions, so you should be able to run it then (unless libcef has been built with the newer instructions enabled…). Unfortunately there are no premade dependency package list for solus, so you’d need to manually install the needed packages and run the setup with --no-packagemanager parameter). Compiling instructions are here:

1 Like

Thank you, I’ll compile it and come back with the results later!

1 Like

Ok, sorry for the long wait time, I compiled it and it still gives me SIGILL error and something like Illegal instruction, even tried Leviathan tests, you know, the pong and other stuff, they gave me the same error, but this time, Thrive and tests didn’t gave me any info, just terminated and SIGILL.
Searching on the web, I’ve found it could a problem with CEF(as you have said), I even found your post in the google chromium project forum :stuck_out_tongue: , tried to compile CEF from source and… GOD, I’m totally lost now, I have no experience at all with this, but I’ll start a fresh CEF again… but what is your opinion about this? Do you think this computer will be able run Thrive if I compile CEF?

That’s why I didn’t try to compile CEF myself and just used the precompiled binaries for it.

I think the concept should apply to CEF (and chromium) as well, that if you compile them with a compiler on your computer, they should automatically limit themselves to the instruction set supported by your CPU, and thus work if you compile them from scratch. Though you’ll want to be pretty careful in selecting the right CEF build, otherwise Leviathan probably won’t work with it. According to the setup script the right CEF version is 75.1.4+g4210896 with chromium-75.0.3770.100

1 Like