Membrane rigidity visual bug

this happens sometimes when the slider is moved all the way to the right with the cursor 2*the distance of the bar from the slider dot


Imagine what its saying is actually what’s gonna happen and you just start flying around the map breaking light speed with negative health.

1 Like

I tried everything I could think of based on your description, but I could not get this bug to appear. Do you have exact steps that would trigger the problem?

i just went into the editor, used up all but 7 of my MP, and slid the dot all the way to the right

You are still not giving me exact steps. Or better yet, please provide save where it is very fast to see the problem happen.

This same issue has been patched at least once before, and since then you are the only one reporting it, which hopefully means that it is extremely rare now. Sadly that also means that it is very difficult to solve because if you can’t get the bug to happen you can waste hours trying to theorize what might go wrong but can’t verify anything.

i repeated the bug and the exact steps i took were starting up the game with mutation cost at .2* being the only relevant one and then hitting p to get to the editor so i could spend all of my mutation points and then moving the slider past -1 MP towards rigid.

Which organelles did you place? When I ask for step by step instructions, I mean that. Anything else is just wasting my time. Or could you please make a save and upload it somewhere, where the only step needed to trigger the bug is dragging the rigidity slider?

just cytoplasm, metabolosomes, and rusticyanin.

i got the save
i also repeated it while just using cytoplasm and placing it in rings around the center hex

The save is not even in the editor, and it doesn’t have the organelles. Make a really detailed list of steps to cause the bug or record a video. Otherwise I will assume that you are purposefully wasting my time and will stop replying, I gave you the benefit of the doubt before but I’m really close to losing that.

1 Like

all you need to do is hit p and click the editor. that’s what i did.


1 Like

Thank you, now we are getting somewhere.

Looking at the video and confirming it myself, I think the problem is trying to move the rigidity slider when exactly at 0 MP. That probably causes a division by zero or some other mistake like that.

I’ve opened an issue: