Microscopic Multicellular - Won't let me modify duplicated cells

I’m trying to get to Macroscopic and have more than two cell types. I have duplicated both cell types and tried to modify the new dups, but the editor just brings me to the original cell type. I can’t switch to the new one to place it either.

Could you please provide more details? So you created 4 total cell types and then editing 2 of those cell types don’t work but editing the 2 other ones does?

I think you need to select the cell by double clicking before actually hitting the modify button.
I DO play Thrive at school, so i should know at least something about it, hopefully.

I’m pretty confident double click does nothing on the cell type selection buttons.

Oof. I guess in less than 24 hours after not playing the game, i already forgot the more advanced controls.
Could you remind me how type duplication works, again?

Selecting a cell type works the same as organelles: you single click on the button for that organelle / cell type. Once a type is selected you can edit it by pressing the specific edit button or just clicking the “cell” tab to switch from the body plan editor to the cell editor.

I could edit the two i duplicated, but it changed all 4 cells. Its like the 2 dups are permanently connected to the orignal ones. It was super weird

when that happens to me a save and reload normally fixes it

This still doesn’t provide enough info to try to get the problem to appear again, unless some other community member can find a way to trigger the bug. We need clear steps that trigger the issue (or most of the time trigger the issue) in order to be able to investigate without wasting hours and hours of Thrive development time on an issue that might still be too rare to “accidentally” stumble on.

I am having the exact same problem. I am on a mac, and as soon as I started multicellular stage and tried putting several cell types together, I would click “next” and show up as my original cell type that I modified. A single cell, floating around and dividing just like a single cellular eukaryote does, watching what I think was supposed to by my “bud” floating away as an independent cell. :*) The game is absolutely awesome btw, keep up the fantastic work!

After saving, my other cell type appeared! It popped into existence! Weird bug haha. Maybe it had always been there but wasn’t visible until I manually saved?

Edit 2
Ok, it seems like my other cell pops into existence a little while after I divide. I’m guessing the budding isn’t animated and thats why it looks the same as single cellular division.

Yes, multicellular growth has no animation. Your body plan gradually grows to include all of the cells as you gain reproduction progress.