Newly Created Nodes Don't Actually Exist

Issue Description

I am working on some popups so i need a new node but when i create it, it does not appear in the scene, this happen for any scene i am using and any nodes i add and it only happen for this project

Your code

My Github is here

Running it in the godot editor

Extra error information

Godot Log

— Debugging process started —
Godot Engine v3.2.2.stable.mono.official -
OpenGL ES 3.0 Renderer: GeForce GTX 1080 Ti/PCIe/SSE2

user:// directory is: C:/Users/joeyl/AppData/Roaming/Thrive
Game logs are written to: C:/Users/joeyl/AppData/Roaming/Thrive/logs latest log is ‘log.txt’
Loaded mod: Plastric Love
Loaded registry for Compound with 11 items
Loaded registry for MembraneType with 6 items
Loaded registry for Background with 11 items
Loaded registry for Biome with 11 items
Loaded registry for BioProcess with 13 items
Loaded registry for OrganelleDefinition with 17 items
Loaded registry for MusicCategory with 3 items
Loaded registry for HelpTexts with 2 items
SimulationParameters loading ended
SimulationParameters are good
Jukebox now playing from: Menu
Jukebox: starting track: res://assets/sounds/main-menu-theme-1.ogg position: 0

1 Like

That remote local header makes me think you are currently running the game.
I haven’t tried adding new nodes when that is the case (just when the game is closed), so that might be the problem?

Edit: my other guess is that the Control is positioned incorrectly so it doesn’t appear visible.

I add the nodes when the game is not running but when i run them they are not there,

It not that they are not visible as i should still see it in the tree

i tried during this to other godot project and i don’t suffer the same issue

I don’t have an issue with Thrive.
Adding a new label:

in game:

I’ve never heard of this kind of thing happening so I can’t really help, you should ask in the Godot community about this issue.

1 Like

i figured it out it was autoloading a old version of the game