0.5.10 Release Candidate Testing

It is once again to test a release candidate.Some of the major features if you decide to test this will be the timed reproduction system, auto-evo exploring tool and various fixes and tweaks in a bunch of places.


Linux: https://dev.revolutionarygamesstudio.com/api/v1/download/37153
SHA3: 6083c8640f776a78783271b46bce2b4dfabe882441b6914dbf5e029cb667e76a

Windows: https://dev.revolutionarygamesstudio.com/api/v1/download/37154
SHA3: c0e40a5db5449018de785f08b585b139b57df1d13ddcc64943cfa144da5db0e9

Windows (32-bit): https://dev.revolutionarygamesstudio.com/api/v1/download/37155
SHA3: e5583495e09aca738f2d2222f11439715fde3bce79652b64fc32ed88010978b7

Mac: https://dev.revolutionarygamesstudio.com/api/v1/download/37156
SHA3: 28f7fd6c3c683b818485aae53ebbde4e1dfda37cf6b041e68bcca6b40639324d

The mac build should work this time right away as I built and tested it on my mac. Even though we haven’t reached the wishlist goal.

Also available as the beta version from Steam and itch.

If you provide feedback please try to focus it on things that we could feasibly fix in a week before the 0.5.10 release.


you KNOW its serious when you can see the hide details box in the community forum home page

I played all the way until the late multicellular editor. However, at this point, once I press the “CONFIRM” button, the game crashes without leaving any message. Find below the link of the save file, just before clicking the “Become macroscopic” button:

Concerning timed reproduction, in the microbe stage feels OK in my opinion. However, in the early multicellular stage, it gets too high. It took about 20 minutes for my final organism made of 20 cells, even with the stores of ammonia and phosphate full. As well, the “instantaneous reproduction” cheat does only grant access to the editor, without creating the full organism. Therefore, in order to access the late multicellular stage, I am forced to have to wait.

Apart from that, the new mucilage agent is very fun to play with and I also enjoyed a lot messing with the auto-evo exploring tool. Good work!


I forgot to add that, in early multicellular, every time I go back into the editor, my cell body plan gets slightly modified. Usually, a couple or so of my cells are moved with respect to the previous editor cycle.

What do you mean?

I can confirm. I didn’t fully debug but it seems like the slime changes now crash the macroscopic prototoype.
Someone needs to either duplicate the microbe HUD changes to the macroscopic or remove those parts from the base mechanics.

I already knew that the balancing is off there as we didn’t get a game designer to balance that part.

Edit: also @aleixcoma are you sure the game logs didn’t have any crash information? We should now have a code change merged that adds an unhandled exception handler.

I can confirm this happened for me as well.

Until then everything worked fine though!

just this

Oh that, I do remember seeing that kind of thing somewhere for a thread but at least for me this thread doesn’t show up anywhere on the forums home page like that.

Yes, that’s the corresponding log:


------------ Begin of Unhandled Exception Log ------------
The following exception prevented the game from running:

System.NullReferenceException: The instance of type NodePath is null.
at Godot.NodePath.GetPtr (Godot.NodePath instance) [0x00003] in <19daba5d5ae94c7483bcc78b7907d0ef>:0
at Godot.Node.GetNode (Godot.NodePath path) [0x0000b] in <19daba5d5ae94c7483bcc78b7907d0ef>:0
at Godot.Node.GetNode[T] (Godot.NodePath path) [0x00000] in <19daba5d5ae94c7483bcc78b7907d0ef>:0
at StageHUDBase1[TStage]._Ready () [0x001d0] in <ccd24901990a444f9e5eed06097dc0c9>:0 at MulticellularHUD._Ready () [0x00000] in <ccd24901990a444f9e5eed06097dc0c9>:0 at (wrapper managed-to-native) Godot.NativeCalls.godot_icall_2_451(intptr,intptr,intptr,bool) at Godot.Node.AddChild (Godot.Node node, System.Boolean legibleUniqueName) [0x00011] in <19daba5d5ae94c7483bcc78b7907d0ef>:0 at SceneManager.SwitchToScene (Godot.Node newSceneRoot, System.Boolean keepOldRoot) [0x00027] in <ccd24901990a444f9e5eed06097dc0c9>:0 at EditorBase2[TAction,TStage].OnEditorExitTransitionFinished () [0x00092] in :0
at LateMulticellularEditor.OnEditorExitTransitionFinished () [0x00007] in :0
at TransitionManager+Sequence.StartNext () [0x00094] in :0
at TransitionManager+Sequence.Process () [0x00087] in :0
at TransitionManager._Process (System.Single delta) [0x00019] in :0

Please provide us with this log, thank you.
------------ End of Unhandled Exception Log ------------

That would have been very useful to see first. As that would have basically almost allowed me to come to the same conclusion I came to after testing myself that the macroscopic stage scene has a configuration issue meaning it’s not playable at all.

Tried out this version. There were two problems:

  1. Substances for “evolution” are being recruited for a very long time, I tried to score the cell with all substances through the cheat mode, everything is being collected for a very long time for the necessary substances for evolution
  2. Productivity in multicellular mode drops significantly, it became a little worse than before (fps 3-6)
1 Like

This version includes the new timed reproduction system that prevents players from skipping through generations too fast even if they are full on compounds.

Have you tried setting the entity limit to “tiny” in the performance options?

1 Like

I have to say that new timed reproduction sometimes takes really long, especially with big or multicellular creatures as mentioned by @aleixcoma .
Also i think i found bug where even single cytoplasm is growing up in really slow pace. Unfortunately i don’t have currently any footage or logs.


Where do I find the logs? The game randomly crashed while in the early multicellular editor.

If you don’t already know the logs folder, you can start Thrive go into the options menu and there in the misc options there’s a button to open the logs folder. The game keeps the last few runs of Thrive worth of logs, so you can open the game a couple of times after the crash without having lost the logs.

That will be adjusted. Before the RC multicellular didn’t get any balancing.

If nothing else we’ll probably at least double the speed there:

Cells need to overcome the base cost to be considered fully grown. The base cost is more than 10 times bigger than a single piece of cytoplasm.


is passive absorption added or is it bug?

Passive absorption is a core part of the timed reproduction system.

Edit: you can check the advanced new game options to see that it is indeed added.


where can we get more gameplay videos of you plaything thrive? lol

1 Like

This seems to be the log in which it crashed
Thrive Possible Crash Log - Pastebin.com

So I tried it out and I gotta say, loving the timed reproduction! Of course, it should be balanced better when it’s fully out, as others have said, but all in all, it opens up new possibilities when it comes to evolution, like making an actual plant cell is viable now, without locking yourself from progressing further.

One mechanic that I noticed though, is that you can’t engulf cells with a specific cell wall now? I don’t remember it being a feature in prior version and I’m not that big of a fan in it’s current state.
Don’t get me wrong, it makes the game more fun by providing a challenge, but I think it’s a little annoying at the moment.
So many cells eventually evolve a cell wall that is non-engulfable, making “hunting” much more difficult. There should be special organ that allows you to break down those walls while engulfing at the cost of a large ATP consumption or some other biological weapon, as the pilus later gets unwieldy, but that’s just my opinion.

I can see this update making the game more fun and rewarding to play, though obviously, things need to balanced.