0.5.3 Release Candidate Testing

It is almost time for 0.5.3 to be released. I have once again prepared a release candidate (RC) for testing. This will basically have all the major features in the full release, but we’ll still have about a week to do bug fixing for any issues found in testing.

Here are the downloads:
SHA3: e3c6c01f3dcf18c52caac0135ebdfbe88585dd00e4ca460f4f69312978c401cf

SHA3: 8918745af8aa1c6f46c8cfad9544c1aa041aa3745e11fcc5e7be63f0c2634c7f

Windows (32-bit):
SHA3: 815debe74e61f3e6b30d8da57663c5655b8349bae7bdd5849ec5e6892434a65c

SHA3: 6f9657cf288e40287177dadf5e7ad145c5e066d01f15e46bfd19838f25bad330

If you are a devbuilds tier supporter or a thrive developer, I’ve set that same version as the current build of the day, so you can easily play it with the launcher.

Once again I ask that if you give feedback now, you’d focus on bugs etc. smaller issues you notice, that we could fix before the full release.

Also now’s the last change to work on translations (until next Friday): https://translate.revolutionarygamesstudio.com/


The game gives me an autosave error everytime I enter and exit the editor (it works normally while in game) Error log: https://pastebin.com/Ru8RmDSU

That looks like the disposed exception from FloatingChunk:

When I first started the game, I’ve noticed that the game launched in fullscreen, but the software didn’t cover all the screen, just the bottom right corner of it, also the game didn’t have sound .

The part of the tutorial which teaches about compounds and glucose showed up just when I collect enough ammonia and phosphates to reproduce, I’m sure that it should appear after I finished the movement tutorial. Also, the reproduction button is still glitched.


I had an exception twice when the game tried to save in the editor.

UPDATE: Now I can’t save anymore

Does it have sound now? Or does sound not work at all? (also check in options that you haven’t muted or turned down the sound).
These sound like Godot bugs. Could you include a full game log (showing the used renderer and any errors from Godot)?

It only appears once you have consumed enough glucose and there is glucose somewhere nearby. Did you get to the editor very fast?

That looks like a bunch of the game rendering is broken.
Another Godot bug affecting your computer?

1 Like

I noticed that the drop-down list of the languages goes out of bounds on my monitor (1366×768). That could be fixed by making it a fixed size and adding a slider to scroll or allow it to dynamically change its dimensions up to a certain threshold, at which point a slider would appear.

Actually, it seems there is a boundary, but the text is not affected by it.

That seems to happen based on the aspect ratio. If it isn’t exactly right the popup position will be offscreen slightly.

@KasterisK do you know which control type is used for the button? I’ll need to know that if I need to try to find related issues / make a bug report to godot.

1 Like

Hello, i got two times auto-save issues.

It uses OptionButton which is just a button derived type to open the dropdown itself (a PopupMenu). There’s already a merged PR in the godot repo for reworking and improving the popup menu, so that it will be possible to set a max size for it. That could at least fix the dropdown getting very long and being cutoff. https://github.com/godotengine/godot/pull/41640

1 Like

Looks like we are waiting for Godot 4 for that as well.

I think OptionButton is supposed to expand until there’s no space on the screen at which point one can scroll, so I think that’s not normal. The upper boundary should have moved up until it reaches the top of the screen.

Here on the image I was able to scroll down because it ran out of space.

The PR KarsterisK linked will probably be a good workaround.

Yes, I did read that in the linked Godot PR. However, I didn’t bother trying to find issues with the option button popup going offscreen like what we are seeing.

I agree. This is why I didn’t bother trying to find solutions / bug reports about the bottom part being cutoff, which is probably a separate bug, but we won’t experience it after we move to Godot 4 and set the max height for the popup.

1 Like

I’ve noticed that when I press a key to move and then release it, Thrive takes a lot of time to notice that I released the key. That time increases with the amount of time I held that key pressed. The amount of time also increases if I lower the CPU frequency (I have a GNOME extension to do that to prevent overheating). There’s no latency with the mouse movement though.
If I press the w key for a few seconds, it moves, and then when I release it, it continues moving in the direction my mouse points and changing direction if I move the mouse. After some seconds it realises I’m not pressing the key anymore.
Since it seems to be related to my CPU frequency: Intel® Celeron® CPU N2840 @ 2.16GHz × 2
I’m using Debian Buster GNU/Linux with Linux 4.19.0-12-amd64.

Edit: seems to be https://github.com/Revolutionary-Games/Thrive/issues/1666
Waiting for Godot, again. :smiley:

Edit2: It seems there was a backport for 3.2: https://github.com/godotengine/godot/pull/42341

I think I saw that as well. Could you find out if Godot 3.2.3 contained that PR? If it doesn’t then presumably the error still exists, and maybe a new issue report to Godot is warranted.

Since the PR was created (25 sep) some days after 3.2.3 was released (17 sep, I think), I don’t think 3.2.3 contains it. So I guess we’ll just have to wait for the next 3.2 or 4.0 release.

Okay, that’s good. 3.2.4 might be coming soon(?).

Ok, the PR is even listed here. I have no idea how to know when the next release comes out.