Cannot start Thrive 0.4.0


#1

I was really excited about this new update but…

Summary

Playing Thrive 0.4.0

Thrive is running. Log output:

Process Started

[ERROR] FileSystem: LoadDataDump: Failed to read file: ./ThriveGame.conf

[INFO] Engine: Command line:

[WARNING] ConsoleInput: Stdin read failed, stopping input thread

[INFO] NetworkHandler: running listening socket on port 55746

[INFO] NetworkHandler: no stored list of master servers, waiting for the update to finish

[INFO] NetworkHandler: Fetching new master server list…

[ERROR] FileSystem: LoadDataDump: Failed to read file: ThrivePersist.txt

[INFO] FileSystem: found 477 files in Data folder with 24 different types of extensions

[INFO] FileSystem: vectors sorted and indexes created, took 998 micro seconds

[INFO] GameModuleLoader: detected following module files:

[INFO] ./Data/Scripts/microbe_stage/microbe_editor/microbe_editor.levgm which contains module “microbe_editor”

[INFO] ./Data/Scripts/microbe_stage/microbe_stage.levgm which contains module “microbe_stage”

AudioManager: Audio Decoder for extension .ogg registered.

AudioManager: Audio Decoder for extension .wav registered.

AudioManager: Audio Decoder for extension .raw registered.

AudioManager: Data Source named FileSystem registered (Priority 0).

Creating resource group General

Creating resource group Internal

Creating resource group Autodetect

SceneManagerFactory for type ‘DefaultSceneManager’ registered.

Registering ResourceManager for type Material

Registering ResourceManager for type Mesh

Registering ResourceManager for type Mesh2

Registering ResourceManager for type OldSkeleton

MovableObjectFactory for type ‘ParticleSystem’ registered.

ArchiveFactory for archive type FileSystem registered.

DDS codec registering

FreeImage version: 3.17.0

This program uses FreeImage, a free, open source image library supporting all common bitmap formats. See http://freeimage.sourceforge.net for details

Supported formats: bmp,ico,jpg,jif,jpeg,jpe,jng,koa,iff,lbm,mng,pbm,pbm,pcd,pcx,pgm,pgm,png,ppm,ppm,ras,tga,targa,tif,tiff,wap,wbmp,wbm,psd,cut,xbm,xpm,gif,hdr,g3,sgi,rgb,rgba,bw,exr,j2k,j2c,jp2,pfm,pct,pict,pic,3fr,arw,bay,bmq,cap,cine,cr2,crw,cs1,dc2,dcr,drf,dsc,dng,erf,fff,ia,iiq,k25,kc2,kdc,mdc,mef,mos,mrw,nef,nrw,orf,pef,ptx,pxn,qtk,raf,raw,rdc,rw2,rwl,rwz,sr2,srf,srw,sti,x3f,webp,jxr,wdp,hdp

ETC codec registering

OITD codec registering

Registering ResourceManager for type HighLevelGpuProgram

MovableObjectFactory for type ‘Decal’ registered.

MovableObjectFactory for type ‘Entity’ registered.

MovableObjectFactory for type ‘Item’ registered.

MovableObjectFactory for type ‘Light’ registered.

MovableObjectFactory for type ‘BillboardSet’ registered.

MovableObjectFactory for type ‘ManualObject2’ registered.

MovableObjectFactory for type ‘BillboardChain’ registered.

MovableObjectFactory for type ‘RibbonTrail’ registered.

MovableObjectFactory for type ‘WireAabb’ registered.

--* OGRE Initialising

--* Version 2.1.0unstable (‘B’)

Loading library RenderSystem_GL3Plus

Installing plugin: GL 3+ RenderSystem

OpenGL 3+ Rendering Subsystem created.

[INFO] Detected audio devices:

[INFO] > OpenAL Soft on Speakers (Realtek High Definition Audio)

[INFO] End of devices

[INFO] SoundDevice: Initializing sound with device: OpenAL Soft on Speakers (Realtek High Definition Audio)

Plugin successfully installed

Loading library Plugin_ParticleFX

Installing plugin: ParticleFX

Particle Emitter Type ‘Point’ registered

Particle Emitter Type ‘Box’ registered

Particle Emitter Type ‘Ellipsoid’ registered

Particle Emitter Type ‘Cylinder’ registered

Particle Emitter Type ‘Ring’ registered

Particle Emitter Type ‘HollowEllipsoid’ registered

Particle Affector Type ‘LinearForce’ registered

Particle Affector Type ‘ColourFader’ registered

Particle Affector Type ‘ColourFader2’ registered

Particle Affector Type ‘ColourImage’ registered

Particle Affector Type ‘ColourInterpolator’ registered

Particle Affector Type ‘Scaler’ registered

Particle Affector Type ‘Rotator’ registered

Particle Affector Type ‘DirectionRandomiser’ registered

Particle Affector Type ‘DeflectorPlane’ registered

Plugin successfully installed

[ERROR] Graphics: Init: no selected render system, invalid variable RenderSystemName, not found/wrong type

[INFO] Graphics: preferred rendering system: “OpenGL.*”

CPU Identifier & Features


  • CPU ID: GenuineIntel: Intel® Pentium® CPU B940 @ 2.00GHz

  • Logical cores: 2

  • SSE: yes

  • SSE2: yes

  • SSE3: yes

  • MMX: yes

  • MMXEXT: yes

  • 3DNOW: no

  • 3DNOWEXT: no

  • CMOV: yes

  • TSC: yes

  • FPU: yes

  • PRO: yes

  • HT: no


*** Starting Win32GL Subsystem ***

[INFO] SDL: display count: 1

[INFO] Display(0, Generic PnP Monitor): top left: (0, 0) size: 1600x900

GL3PlusRenderSystem::_createRenderWindow “Thrive 0.4.0.0”, 1280x720 windowed miscParams: FSAA=4 externalWindowHandle=525844 gamma=true vsync=false

child process exited with code 3221226505

Please help!


(Untrustedlife) #2

32 bit or 64 but system? We have had a few users reporting it not starting. Unfortunately due to the limited amount of hardware we have as devs we couldn’t test on every possible system.


#3

64 bit, previous versions worked fine.


#4

Looks like the game crashes inside the Ogre initialization.
What kind of graphics card you have?


#5

Yeah i knew its going to be a problem
I am using Intel integrated hd graphic


(Untrustedlife) #6

Darn intel. We suspect intel in the bug involving clouds not showing up aswell we all have Nvidia cards except one of us.


#7

I have some pretty new intel on my laptop and it works fine there (except the clouds are a bit too opaque).


#8

I’ll try it on my brothers AMD laptop and hope its gonna work.
EDIT: Its working with like 10 fps