Game launcher comes up with child process exited with code 3221225477

I’ve tried every resource i could including any relevant reports on the forms, as such none of them have worked so far in helping me get closer to playing, godot runs fine on the computer and there are no other issues. My specs can handle thrive just fine.

Welcome, and sorry for this trouble you are experienceing.

So, your issue is that you can’t launch the game when clicking the play button of the launcher, right?

Which OS are you using? May it also be related to access issues (e.g. antivirus)?

Did you try the mono version of Godot? And does that properly open the Godot editor without crashing?

Does the game not give any other output other than the message about exiting? What if you run the game from command prompt (I assume you are on 64 bit windows) and see if it outputs anything extra?

Windows 10 64-bit is the OS i’ve tried other versions and it all comes up the same for some reason, I even double checked the OS and shut down the antivirus program I use temporarily but I will try that again, I will also try and get the command prompts for you hhyyrylainen.

1 Like

Godot mono runs perfectly and literally has no problems, but for some reason the game won’t launch through command prompt either without any extra info at all, simply states the same thing after about 20 seconds and so does the launcher.

Could you try to open and run a game project, like this demo project: GitHub - godotengine/tps-demo: Godot Third Person Shooter with high quality assets and lighting ?
I’m hoping that trying to run an actual game will crash Godot, then you can report that to the Godot developers so that they can investigate (one of the reasons why we switched to Godot is that when the engine doesn’t work we aren’t the ones who need to fix it).

I ran it and it ran fine so it might be something with my computer, I will keep trying out other things and if I find something that works I will say so.

I was next going to suggest you try to compile and run Thrive from the Godot editor to see what happens, but that’s a bit difficult as it requires a fair number of tools: Thrive/setup_instructions.md at master · Revolutionary-Games/Thrive · GitHub

If you do find something out, please let us know. As far as I know you are the first person on whose computer the Godot editor runs fine but Thrive doesn’t.

I managed to get the 32 bit one running for about an hour but now it no longer does so. I am trying to replicate what i did leading up to it to see what can fix the issue in case this happens to anyone else. If there are any alternatives you can think of i would be glad to hear them.

I disabled all the input and output sound devices and that worked in the end, the key was the input devices for some reason, so if godot runs fine but thrive still isnt working then it is the input devices that are somehow messing everything up. Might need to look into that in the future so this issue doesn’t replicate and grow. Audio output should be disabled just in case and it also a bit glitchy having static in it.

Hmmm, well we don’t have a way to control sound output devices in Thrive, so we rely on the engine for that.
It would be nice to find a minimal sample project that just tries to play a sound (and would crash on your computer) with that it’s then easier/possible report the issue to Godot.

1 Like

I have two different sound output devices on my computer so i could test both them to see which one doesn’t like godot by making a small program to run it in.

2 Likes