Making absolutely huge cell in the editor causes the game to crash and now I can't play it

So… This is a pretty funny story. And I don’t have a crash file or logs, I couldn’t figure out how to find them, and I think they aren’t needed for this situation. If you do need them just let me know. I just started playing thrive today and after a while I got bored (no offense this game is awesome), and so I decided to spice things up a bit. I was in freeplay but this also can happen in the normal game, at least if you’re ambitious enough. I noticed that in the cell editor you can zoom out, a lot. I decided to make the biggest cell possible. I added practically a million flagellum and a bunch of mitochondria and chloroplasts, etc. When I hit confirm… The game froze and eventually loaded into the game, still frozen, but it loaded a previous save file and a different cell which I only saw for a few seconds before my game closed. No error message, no “This game is not responding”, and I’m pretty sure I didn’t run out of memory, it just closed. It also closed the launcher. What’s even weirder is that when I went to reopen the game, it wasn’t there on my taskbar where I had it pinned. I eventually found the game and my save files in windows file explorer, so it didn’t uninstall like I had initially thought. However, whenever I go into the launcher to try to play the game again, it gets stuck on “Process started”. I tried playing a different version and the launcher installed it but it also got stuck. I don’t know how to get it to work again. I think a way to avoid this problem would be to make it so there’s a limit to the size of the cell, maybe add a hexagonal grid with a set radius and you can’t build outside of it, or just have a limited number of things you can add in case players want a weirdly shaped cell. Sorry for the really long post.

1 Like

You can press the options (“cog button”) in the launcher, and from there you can see the list of installed thrive versions. Each version has a delete button which you can use to uninstall them. After deleting, when you play that version again, it should get downloaded again. That should probably fix it.

The latest devbuilds use a different save format, so you can’t help with this yet, but if someone were to provide a fully maxed out cell in the form of a save made in the editor, I could try that on my computer to see what happens.

We did some testing and could not get the game to crash even with very huge cells that already quite hinder the microbe editor.

So I’m going to guess that crashing depends on how powerful your computer is.

I did some profiling and I have a save file for the huge cell. I opened an issue for improving the performance:

What are your specs?

Thanks I’ll try that. And yes, now that I think about it, my computer was probably the problem. It runs the normal game just fine but a chonky cell is too much :joy:

Hmmmm… So I ended up having to scour the computer and delete every thrive-related file and when I tried installing the launcher again it says “Installation aborted, setup was not completed successfully.”

If you manually delete any of the launcher installation files (which are completely different from the installed thrive versions), you will break it.
See this thread:

Welp. That’s unfortunate. I can still download the game manually and I can run the game but I can’t use the launcher. If I try to install a future version of the launcher when it comes out will it let me? Or will it have the same problem?

I don’t foresee a change in the installation wizard we use, so it will likely continue to have problems.
As I mentioned in that thread cleaning out your registry from thrive related stuff will probably fix it.

I tried clearing the registry from everything thrive related and it’s still not working

I figured it out. I went to the control panel, then to programs and features, then I found the installer was still there for some reason. Removing it from the list fixed the problem. I can use the launcher once more! And the game loads up just fine. Thanks!