Startup crash


(sad sandwich ✠) #1

started up for the first time and got this error:

Thrive is running. Log output:

Process Started

child process exited with code 3222601732


#2

Do you have intel HD graphics 4000 or older?

If you do please read that linked thread and the thread linked there as to why this can’t really be fixed.

If you have dedicated graphics card or newer intel please post your processed crash dump here (put int on pastebin and post a link). Instructions for finding the crash dump are here:


(sad sandwich ✠) #3

you see i’m guessing the game actually has to start for it to create a .dmp file and as my game doesn’t start it isn’t there (I have checked over it many times and have done name searches)
the error appears as soon as i press play on the launcher

if the above isn’t why the .dmp file isn’t there then i’m listening


#4

So you are saying that what you posted is the full output of the launcher and there are no .dmp files created in the thrive/bin folder?

Is there a file called ThriveLog.txt in thrive/bin? If there isn’t that confirms that the game code does not start running at all.

In that case it is strange that Windows wouldn’t pop up an error dialog box. Could you try directly running Thrive.exe from the thrive/bin folder (you can find the path for it in the error reporting thread)?
Which version of Windows do you have?


(sad sandwich ✠) #5

Yes that is the full output and yes no .dmp files, there isn’t a ThriveLog file either so that confirms that.
When i run Thrive.exe directly from bin a windows error does pop up saying:

“The application was unable to start correctly (0xc0150004).”

I am running windows 10


#6

Just to confirm, do you have 64 bit windows?

Do you have an antivirus that might be deleting some of the thrive files?
To confirm that all the files are fine compare with the contents of the compressed release: https://github.com/Revolutionary-Games/Thrive/releases/download/v0.4.0.2/Thrive-0.4.0.2-WINDOWS-64bit.7z


(sad sandwich ✠) #7

My windows is 64 bit and i have no antivirus programs downloaded, even windows defender is turned off.

The download will take a while so bear with me :slight_smile:


(sad sandwich ✠) #8

I dragged all the files from the download bin into my current bin and skipped the ones that were the same, there was around a 100 or so files that were copied into bin. Tried starting the game again but same error so just to be safe I deleted the bin folder and copied the downloaded one over so now I’m sure there can’t be anything missing (tired starting after that too but same thing happens).


#9

When searching for the error I found some discussions that indicate that that error might not have anything to do with Thrive, but rather that something is wrong with your Windows installation:
https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/error-message-the-application-was-unable-to-start/2b27c3a3-a29f-4385-9dbd-7eec02124fea
https://forums.adobe.com/thread/2294859



https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-winapps-appscat_music/the-application-was-unable-to-start-correctly/58560052-2920-4302-b5f6-bf34e83e337e

This is also maybe related (and has advice on using dependency walker to diagnose where the loading error happens):


(sad sandwich ✠) #10

looking through those threads it seems like that error was popping up on all programs and one user couldn’t launch anything, so I am confused as to why only thrive is affected by this. Other user even downloaded a whole new windows on a different partition and saw no results.
the dependency walker does not support win10 but i will download and try on the win8 version and get back to you.


(sad sandwich ✠) #11

After fiddling about with dependency walker I have no idea what I am doing so I tried following this video:

upon opening Thrive.exe this is what i get


https://gyazo.com/df233625cf1d9b15cdfe9836a757a2c8

i don’t know what do to since i can’t start profiling like in the video becuase it is grayed out due to one of the following

http://www.dependencywalker.com/help/html/hidm_execute.htm

so i’m out of ideas and honestly can’t be bothered anymore for today at least, good luck on finishing the game and thanks for trying to help.