0.4.0.1 Crash Reports


#1

The 0.4.0.1 release includes a new crash reporting tool that will create .dmp files containing detailed crash information.

To find the crash dumps look into your thrive/bin folder and see if you have a file with hexadecimal digits as it’s name, like this: e709d739-416a-43ee-7b902580-9f81d05a.dmp. There is now a basic tool for processing the dumps here: https://dev.revolutionarygamesstudio.com/submit . Also log files are still appreciated.

So please process your crash dump with it (just select the file and hit the submit button) then copy the result to pastebin.com and post the link here. Hopefully in the future that tool will get a feature where it can save the reports it generates.

The launcher places thrive files in:
C:/Users/YOURUSERNAMEHERE/AppData/Roaming/Revolutionary-Games/Launcher or ~/.config/Revolutionary-Games/Launcher

There will be a button to browse the files from the launcher, at some point: https://github.com/Revolutionary-Games/Thrive-Launcher/issues/19


New Release: 0.4.0.1
My Game crashed in 0.4.0
Help me my game wont start
#2

(Der Preuße) #3

Welp, this version crashes more than the previous one. Here are my crash reports:
Report 1
Report 2
Report 3

Also here are my specs

CPU: Intel Core i5-6500 3.20 GHz
GPU: NVDIA GeForce GTX 1060 6GB
16GB RAM


#4

There’s a slight problem with the windows crash dump file handling and it isn’t currently properly loading the symbol files. I’ll need to do some fixing on that before I can check those crashes.

Edit: I had a quick look and manually copied around stuff and it seems that at least the first crash is the process system crash. It’s unfortunate that us developers get that only very rarely and you seem to be experiencing it all the time.


(RizkyPramudyaCJ) #5

Report 1
Pastebin of Report 1
Report 2
Pastebin of Report 2

These are error I encountered on Thrive 0.4.0.1

My Specs
Acer Aspire 4752G
CPU : Intel Core i5-2450M 2.5 GHz
GPU : Intel HD Graphics 3000 and NVIDIA GeForce 610M 1GB
RAM : 4 GB
OS : Windows 7 64 Bit


#6

The crash dump handling tool is now ready: https://dev.revolutionarygamesstudio.com/submit

So please use that to process your .dmp files and post the output of that on pastebin.com to make my life easier.


#7

All of these reports so far are in:

Thread 0 (crashed)
 0  Thrive.exe!thrive::ProcessSystem::Run(Leviathan::GameWorld &) [process_system.cpp : 197 + 0x0]

I think this is related to an existing issue. This is probably the cause that causes it.
I have opened an issue for tracking this crash:

The funny thing is that I had already identified this as a potential problem already in June:

Famous last words: it should be fine


#8

Unfortunately I can’t upload a report for you because of this site’s limitations. However, here’s the processed version: https://hastebin.com/otijubuqow.cpp (I use Hastebin instead of Pastebin because I like Hastebin’s looks more, plus it doesn’t have ads)


#9

That report is interesting. The crash is happening within Ogre (our rendering engine).
Which graphics card do you have? And did I correctly interpret that report that you are using Windows 7?

Edit: could you also put your ThriveLogOGRE.txt on hastebin?


#10

I use Windows 8 with Intel® Integrated 4000 graphics; I have no other graphics. Edit: Here’s your requested log https://hastebin.com/mewuqoyaju.http


#11

Please try updating your drivers. I asked the Ogre devs and they said there is a good chance that a proper driver update for your graphics could fix it.


#12

Can’t do, unfortunately. No driver updates are available as far as I can tell. I guess you’re saying I need a new computer to play Thrive now, just like so many games out there?


#13

Are you absolutely sure you have the latest drivers for your Intel HD graphics?
Because there’s been a few people who have said that thrive worked for them with Intel HD 4000.

If you are using the latest drivers then unfortunately the case is that you can’t play Thrive.

I asked the graphics engine developers about this and they didn’t say about any potential fix other than updating drivers (or us Thrive developers supporting both OpenGL and DirectX, which would be a huge trouble for us):
https://forums.ogre3d.org/viewtopic.php?p=543802#p543802


Help! My thrive crashes on start
#14

Unfortunately, there appear to be no updates…

Detailed Report from Intel Driver & Support Assistant

Intel® Driver & Support Assistant

Detailed Report

Last scan: 2/1/2019 16:08

Computer

Dell Inc. Inspiron 3521
System Manufacturer Dell Inc.
System Model Inspiron 3521
System Type Mobile
Motherboard Manufacturer Dell Inc.
Motherboard Product 033MX4
BIOS Version A07
SMBIOS Version 2.7
Secure Boot On

Operating System

Microsoft Windows 8 (64-bit)
OS Build 6.2.9200
Locale English (United States)
Windows Directory C:\Windows
System Directory C:\Windows\system32
.NET Framework Versions 2.0.50727.4927, 3.0.30729.4926, 3.5.30729.4926, 4.0.0.0, 4.5.51209
Default Internet Browser Internet Explorer 10.0.9200.17607
Installed Internet Browsers Mozilla Firefox, Google Chrome, Internet Explorer 10.0.9200.17607

Processor

Intel® Core™ i3-3227U CPU @ 1.90GHz
Manufacturer GenuineIntel
Description Intel64 Family 6 Model 58 Stepping 9
Architecture x64

of Cores 2

Current Clock Speed 1901 MHz
Current Voltage 9.
Level 2 Cache 256 Kb
Level 3 Cache 3072 Kb
Processor Id BFEBFBFF000306A9
Revision 14857
Availability Running at full power

Graphics

Intel® HD Graphics 4000
Adapter Compatibility Intel Corporation
Video Processor Intel® HD Graphics Family
Resolution 1366 x 768
Bits Per Pixel 32
Number of Colors 4294967296
Refresh Rate - Current 60 Hz
Refresh Rate - Maximum 60 Hz
Refresh Rate - Minimum 40 Hz
Driver Provider Intel Corporation
Driver Version 9.17.10.2867
Driver Date 9/26/2012
Adapter DAC Type Internal
Adapter RAM 2.06 GB
Availability Running at full power
Status This device is working properly.
Location PCI bus 0, device 2, function 0
Device Id PCI\VEN_8086&DEV_0166&SUBSYS_05971028&REV_09\3&11583659&0&10

Audio

Intel® Display Audio
Driver Provider Intel® Corporation
Driver Version 6.14.0.3097
Driver Date 6/19/2012
Device Id HDAUDIO\FUNC_01&VEN_8086&DEV_2806&SUBSYS_80860101&REV_1000\4&2AF4EA01&0&0301
Realtek High Definition Audio
Driver Provider Realtek Semiconductor Corp.
Driver Version 6.0.1.6788
Driver Date 11/27/2012
Device Id HDAUDIO\FUNC_01&VEN_10EC&DEV_0282&SUBSYS_10280597&REV_1000\4&2AF4EA01&0&0001

Networking and I/O

Dell Wireless 1703 802.11b/g/n (2.4GHz)
Manufacturer Atheros Communications Inc.
Availability Running at full power
Status This device is working properly.
Installed True
MAC Address 1C:3E:84:8D:CD:EB
Service Name athr
Driver Provider Atheros Communications Inc.
Driver Version 10.0.0.222
Driver Date 12/16/2012
Device Id PCI\VEN_168C&DEV_0032&SUBSYS_02091028&REV_01\4&94546EF&0&00E1
Revision 01
Realtek PCIe FE Family Controller
Manufacturer Realtek
Availability Running at full power
Status This device is working properly.
Installed True
MAC Address 74:86:7A:18:23:A2
Service Name RTL8168
Driver Provider Realtek
Driver Version 8.2.612.2012
Driver Date 6/12/2012
Device Id PCI\VEN_10EC&DEV_8136&SUBSYS_05971028&REV_05\4&6521971&0&00E0
Revision 05

Memory

6 GB
Physical Memory - Total 6 GB
Physical Memory - Available 3.93 GB
Virtual Memory - Total 12.17 GB
Virtual Memory - Available 9.45 GB
Page File C:\pagefile.sys
Page File Space 6.25 GB

Storage

ST500LT012-9WS142
Capacity 465.76 GB
Firmware Version 0002SDM1
Serial Number W0V9EKLX
Partitions 5
Driver Provider Microsoft
Driver Version 6.2.9200.16736
Driver Date 6/21/2006
Device Id SCSI\DISK&VEN_ATA&PROD_ST500LT012-9WS14\4&178BB2E7&0&000000
C:
File System NTFS
Compressed False
Capacity 452.82 GB
Free Space 63.64 GB


(TheSunisGreatNitrogenBest) #15

https://hastebin.com/xaqejaquka.sql

Specs:
Windows 7 Ultimate
Service Pack 1

Processor AMD A8-7600 Radeon R7, 10 Compute Cores 4C+6G 3.10GHz
Installed memory (RAM): 8.00 GB (3.94 GB usable)
System type: 64-bit Operating System
Pen and Touch: No Pen or Touch Input is available for this Display


#16

That is also the process crash. I think we have fixed it.

I have invited you to test the patch before it is made public, to confirm that it works now.


(Oliveriver) #17

I suppose @hhyyrylainen will want to make a new thread for this, but we have 0.4.0.2 out now with crash fixes for the most common crashes.

So play that too I guess.


#18

I hope we have the game fixed enough that we won’t be getting a flood of crash reports.
And thus won’t be needing a central thread.

Note: if the game doesn’t start for you and you have intel HD 4000 submitting a crash report doesn’t help. (this is directed towards people about to submit a crash report)


#19